# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(\S*)watch\?v=(\S*)/\1embed\/\2/gm;t' <<< "https://www.youtube.com/watch?v=QlNc-jb4ESk&t"