import Foundation
let pattern = #"(\S*)watch\?v=(\S*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"https://www.youtube.com/watch?v=QlNc-jb4ESk&t"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1embed/\2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)