const regex = /(\S*)watch\?v=(\S*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\S*)watch\\?v=(\\S*)', 'gm')
const str = `https://www.youtube.com/watch?v=QlNc-jb4ESk&t`;
const subst = `\1embed/\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);