using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\S*)watch\?v=(\S*)";
string substitution = @"\1embed/\2";
string input = @"https://www.youtube.com/watch?v=QlNc-jb4ESk&t";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}