use strict;
my $str = 'https://www.youtube.com/watch?v=QlNc-jb4ESk&t';
my $regex = qr/(\S*)watch\?v=(\S*)/mp;
my $subst = '\\1embed/\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";