$re = '/(\S*)watch\?v=(\S*)/m';
$str = 'https://www.youtube.com/watch?v=QlNc-jb4ESk&t';
$subst = "\1embed/\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;