package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\S*)watch\?v=(\S*)`)
var str = `https://www.youtube.com/watch?v=QlNc-jb4ESk&t`
var substitution = "\1embed/\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}