re = /(\S*)watch\?v=(\S*)/m
str = 'https://www.youtube.com/watch?v=QlNc-jb4ESk&t'
subst = '\\1embed/\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result