#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\S*)watch\?v=(\S*)"
Local $sString = "https://www.youtube.com/watch?v=QlNc-jb4ESk&t"
Local $sSubst = "\1embed/\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)