# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\\/woltlab-quote>/[quote=$1, post:$1"]$3[\/quote]/sim;t' <<< "<woltlab-quote data-author=\"gebruikersnaam\" data-link=\"https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047\">aaaaaaaaaaaaa</woltlab-quote>"