import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\<woltlab-quote data-author=\\\"(.*)\\\"\\s.*\\?postID=(\\d*).*\\\">(.*)<\\/woltlab-quote>";
final String string = "<woltlab-quote data-author=\"gebruikersnaam\" data-link=\"https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047\">aaaaaaaaaaaaa</woltlab-quote>";
final String subst = "[quote=$1, post:$1\"]$3[/quote]";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}