#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?sim)\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\/woltlab-quote>"
Local $sString = "<woltlab-quote data-author="gebruikersnaam" data-link="https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047">aaaaaaaaaaaaa</woltlab-quote>"
Local $sSubst = "[quote=$1, post:$1"]$3[/quote]"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)