// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?sim)\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\/woltlab-quote>"#).unwrap();
let string = "<woltlab-quote data-author=\"gebruikersnaam\" data-link=\"https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047\">aaaaaaaaaaaaa</woltlab-quote>";
let substitution = "[quote=$1, post:$1\"]$3[/quote]";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}