using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\<woltlab-quote data-author=\""(.*)\""\s.*\?postID=(\d*).*\"">(.*)<\/woltlab-quote>";
string substitution = @"[quote=$1, post:$1""]$3[/quote]";
string input = @"<woltlab-quote data-author=""gebruikersnaam"" data-link=""https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047"">aaaaaaaaaaaaa</woltlab-quote>";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}