$re = '/\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\/woltlab-quote>/sim';
$str = '<woltlab-quote data-author="gebruikersnaam" data-link="https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047">aaaaaaaaaaaaa</woltlab-quote>';
$subst = "[quote=$1, post:$1\"]$3[/quote]";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;