# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\/woltlab-quote>"
test_str = "<woltlab-quote data-author=\"gebruikersnaam\" data-link=\"https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047\">aaaaaaaaaaaaa</woltlab-quote>"
subst = "[quote=$1, post:$1\"]$3[/quote]"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 1, re.DOTALL | re.IGNORECASE | re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.