const regex = /\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\/woltlab-quote>/sim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\<woltlab-quote data-author=\\"(.*)\\"\\s.*\\?postID=(\\d*).*\\">(.*)<\\\/woltlab-quote>', 'sim')
const str = `<woltlab-quote data-author="gebruikersnaam" data-link="https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047">aaaaaaaaaaaaa</woltlab-quote>`;
const subst = `[quote=$1, post:$1"]$3[/quote]`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);