use strict;
my $str = '<woltlab-quote data-author="gebruikersnaam" data-link="https://website.be/topic/26-wat-luister-je-nu/?postID=47047#post47047">aaaaaaaaaaaaa</woltlab-quote>';
my $regex = qr/\<woltlab-quote data-author=\"(.*)\"\s.*\?postID=(\d*).*\">(.*)<\/woltlab-quote>/simp;
my $subst = '[quote=$1, post:$1"]$3[/quote]';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";