# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^()\n–]*\(([0-9]+)\)[^()\n–]*/ \1 /g;t' <<< "(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)"