use strict;
my $str = '(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)';
my $regex = qr/[^()\n–]*\(([0-9]+)\)[^()\n–]*/p;
my $subst = ' \\1 ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";