const regex = /[^()\n–]*\(([0-9]+)\)[^()\n–]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^()\\n–]*\\(([0-9]+)\\)[^()\\n–]*', 'g')
const str = `(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)`;
const subst = ` \1 `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);