import Foundation
let pattern = #"[^()\n–]*\(([0-9]+)\)[^()\n–]*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" \1 "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)