#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[^()\n–]*\(([0-9]+)\)[^()\n–]*"
Local $sString = "(2) 1G–1G (0)" & @CRLF & _
"(1) 1G–1G (4)" & @CRLF & _
"(2) 1G–1G (0)"
Local $sSubst = " \1 "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)