import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^()\\n–]*\\(([0-9]+)\\)[^()\\n–]*";
final String string = "(2) 1G–1G (0)\n"
+ "(1) 1G–1G (4)\n"
+ "(2) 1G–1G (0)";
final String subst = " \\1 ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}