package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^()\n–]*\(([0-9]+)\)[^()\n–]*`)
var str = `(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)`
var substitution = " \1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}