using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^()\n–]*\(([0-9]+)\)[^()\n–]*";
string substitution = @" \1 ";
string input = @"(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}