$re = '/[^()\n–]*\(([0-9]+)\)[^()\n–]*/';
$str = '(2) 1G–1G (0)
(1) 1G–1G (4)
(2) 1G–1G (0)';
$subst = " \1 ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;