#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$"
Local $sString = "feat: NSPS2-1277 A valid commit message" & @CRLF & _
"chore:NSPS2-1277 A valid commit message" & @CRLF & _
"fix: NSPS2-1277 A valid commit message" & @CRLF & _
"security: NSPS2-1277 A valid commit message" & @CRLF & _
"wip: NSPS2-1277 A valid commit message"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")