import re
regex = re.compile(r"^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$", flags=re.MULTILINE)
test_str = ("feat: NSPS2-1277 A valid commit message\n"
"chore:NSPS2-1277 A valid commit message\n"
"fix: NSPS2-1277 A valid commit message\n"
"security: NSPS2-1277 A valid commit message\n"
"wip: NSPS2-1277 A valid commit message")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")