const regex = /^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$', 'gm')
const str = `feat: NSPS2-1277 A valid commit message
chore:NSPS2-1277 A valid commit message
fix: NSPS2-1277 A valid commit message
security: NSPS2-1277 A valid commit message
wip: NSPS2-1277 A valid commit message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}