import Foundation
let pattern = #"^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
feat: NSPS2-1277 A valid commit message
chore:NSPS2-1277 A valid commit message
fix: NSPS2-1277 A valid commit message
security: NSPS2-1277 A valid commit message
wip: NSPS2-1277 A valid commit message
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)