package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$`)
var str = `feat: NSPS2-1277 A valid commit message
chore:NSPS2-1277 A valid commit message
fix: NSPS2-1277 A valid commit message
security: NSPS2-1277 A valid commit message
wip: NSPS2-1277 A valid commit message`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}