using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$";
string input = @"feat: NSPS2-1277 A valid commit message
chore:NSPS2-1277 A valid commit message
fix: NSPS2-1277 A valid commit message
security: NSPS2-1277 A valid commit message
wip: NSPS2-1277 A valid commit message";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}