re = /^(feat|chore|fix|security|wip):[ ]?[A-Z0-9]+-[0-9]+.{3,}$/m
str = 'feat: NSPS2-1277 A valid commit message
chore:NSPS2-1277 A valid commit message
fix: NSPS2-1277 A valid commit message
security: NSPS2-1277 A valid commit message
wip: NSPS2-1277 A valid commit message'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end