# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<br>| |\n//g;t' <<< "<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>"