// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"<br>| |\n").unwrap();
let string = "<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}