$re = '/<br>| |\n/';
$str = '<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;