re = /<br>| |\n/
str = '<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result