using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<br>| |\n";
string substitution = @"";
string input = @"<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}