import Foundation
let pattern = #"<br>| |\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)