use strict;
my $str = '<span>Here is some<br></span><br> <span><span>Here is some text</span><br><span>
<br> </span></span><br><br>';
my $regex = qr/<br>| |\n/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";