# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*folder\.detail\\subfolder\\subfolder\\.*$//g;t' <<< "folder.detail\subfolder\subfolder\
"