package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*folder\.detail\\subfolder\\subfolder\\.*$`)
var str = `folder.detail\subfolder\subfolder\
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}