const regex = /.*folder\.detail\\subfolder\\subfolder\\.*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*folder\\.detail\\\\subfolder\\\\subfolder\\\\.*$', 'g')
const str = `folder.detail\\subfolder\\subfolder\\
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);