import Foundation
let pattern = #".*folder\.detail\\subfolder\\subfolder\\.*$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
folder.detail\subfolder\subfolder\
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)