#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = ".*folder\.detail\\subfolder\\subfolder\\.*$"
Local $sString = "folder.detail\subfolder\subfolder\" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)