using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*folder\.detail\\subfolder\\subfolder\\.*$";
string substitution = @"";
string input = @"folder.detail\subfolder\subfolder\
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}