use strict;
my $str = 'folder.detail\\subfolder\\subfolder\\
';
my $regex = qr/.*folder\.detail\\subfolder\\subfolder\\.*$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";