$re = '/.*folder\.detail\\\\subfolder\\\\subfolder\\\\.*$/';
$str = 'folder.detail\\subfolder\\subfolder\\
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;