# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?<object>[-\w]+)\/([-\w]+)$/$2 - \/ - $1/g;t' <<< "Abc-def/edg"